Ask Your Question

Revision history [back]

I have same problem(similar?). I installed puppet on windows and it shows me: C:/Ruby21-x64/lib/ruby/2.1.0/net/http.rb:922:in `connect': SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (Faraday::SSLError) it tries to connect to forgeapi.puppetlabs.com

and puppet agent --test print this Error: Could not request certificate: getaddrinfo: No such host is known. Exiting; failed to retrieve certificate and waitforcert is disabled

is there a way to solve this?

edit: maybe I posted it wrong place. I found this issue: https://ask.puppetlabs.com/question/250/could-not-connect-via-https-to-httpsforgepuppetlabscom/ and https://ask.puppetlabs.com/answers/251/revisions/ and I have same problem with forgeapi.puppetlabs.com

openssl s_client -showcerts -connect forgeapi.puppetlabs.com:443 shows Verify return code: 20 (unable to get local issuer certificate)

I've tried adding https://www.geotrust.com/resources/root_certificates/certificates/GeoTrust_Global_CA.pem into windows certificates, but it doesnt seem to help