About | FAQ | Help
Ask Your Question

Revision history [back]

Has the pe-memcached script started the memcached process correctly? What do you see when you run the command:

ps uaxww | grep memcached

If memcached is running, check to see that it's listening on the interface and port that PE expects it to.

Has the pe-memcached script started the memcached process correctly? What do you see when you run the command:

ps uaxww | grep memcached

If memcached is running, check to see that it's listening on the interface and port that PE expects it to.

Also, please check the solution in this similar question from a little while ago. In that case, the /etc/hosts file needed to be modified to add an entry for localhost.

Has the pe-memcached script started the memcached process correctly? What do you see when you run the command:

ps uaxww | grep memcached

If memcached is running, check to see that it's listening on the interface and port that PE expects it to.

Also, please check the solution in this similar question from a little while ago. In that case, the /etc/hosts file needed to be modified to add an entry for localhost.


I am not a Rails expert, but after some digging, I discovered a few things about PE's use of memcached:

  • You can change the port that PE's memcached daemon listens on by modifying the PORT setting in /etc/sysconfig/pe-memcached. You can also change the listening interface if needed.
  • Next, change the port that live management code uses to connect to memcached in the file /opt/puppet/share/live-management/lib/emcee/memcache_cache.rb. The easiest way to do that is search for "11211", then change it to your preferred port number.

The second step is a bit ugly because you are changing Puppet code directly, but I don't see any hooks in there to change the port through a configuration option. If some Ruby expert can correct me on that, I will be happy to update these instructions.

I made this change on my test machine, and live management continues to function correctly.