Ask Your Question

Revision history [back]

Found the solution (or workaround) myself:

puppetmaster uses facter's fqdn value to find it's own hostname. Setting the fqdn in /etc/facter/facts.d seems to solve the problem.