Ask Your Question

Revision history [back]

My workaround until puppet fixes its own up2date modules ;-)

file { '/etc/profile.d/disable-puppet-deprecation-warning.sh':
    ensure  => file,
    mode  => '0755',
    content => "export STDLIB_LOG_DEPRECATIONS=false"

}

My workaround until puppet fixes its own up2date modules ;-)

 file { '/etc/profile.d/disable-puppet-deprecation-warning.sh':
     ensure  => file,
     mode  => '0755',
     content => "export STDLIB_LOG_DEPRECATIONS=false"
}

}

My workaround until puppet fixes its own up2date modules ;-)

 $puppet_defaults = @(END)
# Managed by puppet. Do not change anything here !!!
# You may specify parameters to the puppet client here
#PUPPET_EXTRA_OPTS=--waitforcert=500
STDLIB_LOG_DEPRECATIONS=false
END

file { '/etc/profile.d/disable-puppet-deprecation-warning.sh':
'/etc/default/puppet':
        ensure  => file,
        mode  => '0755',
'0644',
        content => "export STDLIB_LOG_DEPRECATIONS=false"
inline_epp($puppet_defaults, {})
}

exec { 'restart-puppet-agent':
    command     => '/usr/sbin/service puppet restart',
    user        => 'root',
    refreshonly => true,
    subscribe   => File['/etc/default/puppet']
}