Ask Your Question

Revision history [back]

You've got a lot going on there. It's failing very early:

  • yum install -y puppet-agent-5.3.3

Note the dependency failurs.

Package puppet-agent.x86_64 0:5.3.3-1.el7

Oracle 6.5 is not equivalent to RHEL 7. It's equivalent to RHEL 6. It looks like that node is pointed to the wrong upstream yum repository., probably with a file in /etc/yum.repos.d/