Ask Your Question
2

can't start puppet-dashboard service

asked 2013-04-21 08:40:53 -0600

updated 2013-04-21 08:50:32 -0600

jonn gravatar image

I can't start puppet-dashboard service I'm using:

  • ubuntu 12.04.2
  • rubygems 1.8.15-1ubuntu0.1
  • rake (10.0.3)
  • ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]
  • puppet-dashboard 1.2.23-1puppetlabs1

the following output is the result of start puppet-dashboard service

 * Starting Puppet Dashboard
NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
Gem.source_index called from /usr/share/puppet-dashboard/script/../config/../vendor/rails/railties/lib/rails/gem_dependency.rb:21.
NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It will be removed on or after 2011-11-01.
Gem::SourceIndex#initialize called ...
(more)
edit retag flag offensive close merge delete

7 Answers

Sort by ยป oldest newest most voted
1

answered 2013-07-15 11:30:39 -0600

graham_m_dunn gravatar image

updated 2013-07-15 11:31:12 -0600

Compare /var/run/puppet-dashboard.pid and the pid of the puppet-dashboard process from ps auxww | grep puppet-dashboard. If they don't match, then the check_puppet_dashboard_status() call in init.d/puppet-dashboard is going to fail, despite the process actually running.

I think this is a bug in the init script for puppet-dashboard.

See bug #20325

workaround is to comment out the check_puppet_dashboard_status() call.

edit flag offensive delete link more
0

answered 2013-10-20 04:33:56 -0600

Not sure if you resolved this already, but for me I discovered that the init script was setting/defaulting DASHBOARD_ENVIRONMENT variable to "production" and in my database.yml configuration file, I defined my database parameters under the "development:" header. Even setting this variable and exporting it from my shell, it still set it to "production" instead of development.

Based on that, the two fixes are either: 1.) hard code (not best practice) the DASHBOARD_ENVIRONMENT variable to the header ("production:"||"development:"||"test:") your database parameters are under in the database.yml config file 2.) Put your database parameters under the "production ... (more)

edit flag offensive delete link more
0

answered 2013-11-28 08:01:17 -0600

mgjk gravatar image

I had to install rubygems 1.3.7

"do not use the rubygems packaged with the operating system"

http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html

It provides instructions to fix it.

Afterwards, due to errors I had to run the recommended:

root@example:/usr/share/puppet-dashboard# rake gems:refresh_specs

Then finally I had to comment out check_puppet_dashboard_status() in /etc/init.d/puppet-dashboard (line 55 on Ubuntu) as described by grahammdunn

For setting up the database, I looked at http://www.craigdunn.org/2010/08/part-3-installing-puppet-dashboard-on-centos-puppet-2-6-1/ for help, it might not be necessary though depending on your install.

edit flag offensive delete link more
0

answered 2013-04-21 17:14:46 -0600

ramindk gravatar image

updated 2013-04-22 10:25:44 -0600

Without seeing the error log, /path/to/puppet-dashboard/log/${env_you_run_as}.log my guess is that your version of rake is way too new or rack is missing. I'd remove the gem installed version of rake and make sure the packages rake and ruby-rack are installed.

IIRC 1.2.23 allows the use of a wider range of rack packages. However if you see in the logs that it is complaining about the version gem install rack -v1.1.6 should fix it.

edit flag offensive delete link more

Comments

Same problem here can't find any log into: /var/log/puppet-dashboard/ and gem install rack -v1.1.6 didn't fix it

Perki gravatar imagePerki ( 2013-05-14 08:22:57 -0600 )edit

Logs will be in the puppet-dashboard directory, not /var/log/ Nothing I can help you with until you find the logs.

ramindk gravatar imageramindk ( 2013-05-14 10:11:40 -0600 )edit

Same problem on Debian 6.

strangeman gravatar imagestrangeman ( 2013-06-03 20:41:57 -0600 )edit

@strangeman then make a new question WITH LOGS! No one can tell what's broken until we actually see what the application is complaining about.

ramindk gravatar imageramindk ( 2013-06-04 10:55:10 -0600 )edit

@ramindk logs are empty. /var/log/puppet-dashboard/, /var/log/puppet/masterhttp.log, /usr/share/puppet-dashboard/log/ - no one relevant string. When I run direct from console (command '/usr/bin/ruby ...(more)

strangeman gravatar imagestrangeman ( 2013-06-04 15:47:11 -0600 )edit
0

answered 2014-09-16 14:53:03 -0600

solved by changing the line 46 (/etc/init.d/puppet-dashboard);

of: -d

for: &

edit flag offensive delete link more
0

answered 2013-10-03 03:18:46 -0600

updated 2013-10-03 03:36:53 -0600

i have this problem with debian 7. did anyone finally get this error fixed?

mine is:

rubygems 1.8.24-1 rake 0.9.2.2-4 ruby 1:1.9.3 puppet-dashboard 1.2.3-1

edit flag offensive delete link more
0

answered 2013-06-03 20:47:14 -0600

updated 2013-06-03 20:47:30 -0600

Installing ruby-rgen and updating puppetmaster and puppetmaster-common (from puppetlabs repo) helps for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-21 08:40:53 -0600

Seen: 4,519 times

Last updated: Nov 28 '13