Ask Your Question
0

Solaris x86 upgrade errors with noop option

asked 2013-04-21 23:27:56 -0600

Ash gravatar image

Got the following while checking the answer file for the 2.7.2 to 2.8.1 upgrade on Solaris 10 x86.

[solaris10]::[root]:/var/tmp/puppet-enterprise-2.8.1-solaris-10-i386$: ./puppet-enterprise-upgrader -n -a ANSWER_FILE

------------------------------------------------------------------------

STEP 1: READ ANSWERS FROM FILE

## Reading answers from file: ./ANSWER_FILE
grep: illegal option -- q
grep: illegal option -- E
Usage: grep -hblcnsviw pattern file . . .
grep: illegal option -- q
grep: illegal option -- E
Usage: grep -hblcnsviw pattern file . . .
!! ERROR: ActiveMQ requires Java of version 1.6 or 1.7. The found java
(/usr/bin/java) is not version 1.6 or 1.7

========================================================================
[solaris10]::[root]:/var/tmp/puppet-enterprise-2 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-04-22 02:11:48 -0600

jonn gravatar image

Hi - I don't have a Solaris server to test this anymore, but it looks like the installer may be assuming that the XPG4 version of grep (from /usr/xpg4/bin - the one that supports switches like "-q" and "-E") occurs first in your PATH. I would suggest reporting this to support.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-04-21 23:27:56 -0600

Seen: 194 times

Last updated: Apr 22 '13