Ask Your Question
1

An error occured trying to load the certificate requests. Reload this page to try again.

asked 2014-06-16 13:15:15 -0600

Red Cricket gravatar image

Hi,

I just installed PE 3.2.3 and when I try to add nodes by running puppet agent -t on the node I do not see the Node Request in the Puppet Dash Board. When I click on the "? Node Request" link I get this error message:

An error occured trying to load the certificate requests. Reload this page to try again.
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-06-16 15:04:49 -0600

Red Cricket gravatar image

uninstalling with puppet-enterprise-uninstaller and reinstalling fixed the issue.

edit flag offensive delete link more

Comments

But this is not the way to fix it. If we have master controlling production nodes and we install kernel updates on master which requires machine to get rebooted, then re-installing pe will definitely mess up environment.

ankur0101 gravatar imageankur0101 ( 2015-03-04 23:29:57 -0600 )edit

It would mess up YOUR environment. Sounds like you have to DR planning to do :/

Red Cricket gravatar imageRed Cricket ( 2015-03-25 11:27:16 -0600 )edit
0

answered 2016-04-08 17:48:15 -0600

AXE-Labs gravatar image

I've not figured out how to fix this, but a work around is to do node requests from the CLI:

puppet cert list
puppet cert sign $HOST2SIGN
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-16 13:15:15 -0600

Seen: 933 times

Last updated: Apr 08 '16