Ask Your Question
0

Puppet won't create Admin account

asked 2013-04-22 12:50:26 -0500

After modifying puppet file and adding the local hosts' rsa keys, userid, etc., puppet fails to create the Admin account. Here's what I did:

  1. ssh'd to remote server
  2. cd /etc/puppet/manifest/config
  3. edit puppet file
  4. run "ssh-add ~/.ssh/id_rsa" and "ssh-add -l" on the localhost.
  5. run "puppetrunallclients" on the remote server

After the last step, puppet typically creates the Admin account. To verify this I just do an "ls /home" and I see the account. But for this particular server, puppet doesn't create the account. Am I missing something?

edit retag flag offensive close merge delete

Comments

please add more detail...
1. (as root?)
2. what is in there?
3. what did you edit and why?
4. what for?
5. heh?
is your puppet-daemon running?

ppuschmann gravatar imageppuschmann ( 2013-04-22 13:33:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-04-22 14:00:26 -0500

When you're running a puppetmaster, the only things you'd need to edit on your client should be:

  • puppet.conf (or /etc/default/puppet or somethink like this) to set the name of your puppetmaster
  • use puppetd --test --noop (then sign your client's ssl-key on the puppetmaster with puppetca / puppet cert ... )
  • fire up your puppet agent on the client
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-22 12:50:26 -0500

Seen: 53 times

Last updated: Apr 22 '13