Ask Your Question
0

How to set environment variables within a manifest

asked 2013-04-22 17:48:53 -0500

Ash gravatar image

updated 2013-04-22 18:17:18 -0500

I need to add a directory to PATH for the module to make use of.

The package -> provider option allows me to specify a non standard provider for the OS, but its directory is not in the system PATH.

I also need to add /usr/xpg4/bin to PATH to work around this bug (https://ask.puppetlabs.com/question/1074/solaris-x86-upgrade-errors-with-noop-option) when I remotely upgrade the puppet agent.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-04-23 03:33:22 -0500

jonn gravatar image

Which provider are you using to manage your packages? As described in this link:

When required binaries are specified for providers, fully qualifed paths indicate that the binary must exist at that specific path and unqualified binaries indicate that Puppet will search for the binary using the shell path.

If the provider searches the shell path, then you can set this in puppet.conf:

# The shell search path.  Defaults to whatever is inherited
# from the parent process.
# The default value is 'none'.
# path = none

However if the provider specifies the path, then you'll need to make sure that it ... (more)

edit flag offensive delete link more

Comments

The provider I meant was rpm, instead of Solaris's pkgadd in the package resource type. Specifying the full path to rpm just gets the error "Invalid package provider". Can ...(more)

Ash gravatar imageAsh ( 2013-04-23 16:16:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-04-22 17:48:53 -0500

Seen: 617 times

Last updated: Apr 23 '13