Ask Your Question
0

Infinite redirection loop after install

asked 2014-06-24 15:51:57 -0500

wsanders gravatar image

updated 2014-06-24 17:10:05 -0500

Just installed 3.4.3.6-1.pe.el6, after authenticating on the cas login page, I get a redirect loop: "The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

I am accepting all cookies, DNS is set up correctly (I am using the FQDN of the host as the login URL), except that a PTR record doesn't exist for the host. I also have another web service running on port 80 on this host. Does puppet need to be able to use port 80 in addition to 443 to be able to work? Is a PTR required?

I generated a support gzip - which log file do I look in to see what's looping?

Thanks -w

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-06-24 17:18:53 -0500

wsanders gravatar image

A reinstall fixed. This was a result of entering a non-default answer to "The puppet master's certificate can contain DNS aliases; agent nodes will only trust the master if they reach it at its certname or one of these official aliases. Puppet master's DNS aliases (comma-separated list)? [Default: puppet,puppet.internal.intraware.com,sclog-04,sclog-04.internal.intraware.com]"

I entered only the real host names of the systems and did not include the "puppet...." aliases.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-24 15:51:57 -0500

Seen: 169 times

Last updated: Jun 24 '14