Ask Your Question
0

Puppetdb node not shown in puppet console after installation of PE

asked 2014-06-27 23:14:06 -0500

GajaDevOps gravatar image

updated 2014-06-28 00:31:19 -0500

HI,

I have installed new PE 3.2.4 with console and puppetdb on same machine. But when I open puppet console, i dont see puppet node displayed under nodes section.

I am trying to edit jetti.ini file for puppetdb and update host and ssl host values. Now to update these values, I need to change its parameters in puppetdb class for puppetdb node.

Currently these values are getting reverted back after puppet run which is expected:

Notice: /Stage[main]/Pepuppetdb::Server::Jettyini/Inisetting[puppetdbhost]/value: value changed '0.0.0.0' to 'localhost' Notice: /Stage[main]/Pepuppetdb::Server::Jettyini/Inisetting[puppetdbsslhost]/value: value changed '0.0.0.0' to 'puppet-host.example.com'

Appreciate any inputs on this.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-06-29 08:00:07 -0500

WhatsARanjit gravatar image

You should see the master node in the list. Click into that and under the class list, you should see pepuppetdb. You can edit parameters listenaddress and listen_port parameters for that class.

edit flag offensive delete link more

Comments

Thanks. That is what i was looking for.

GajaDevOps gravatar imageGajaDevOps ( 2014-06-29 22:32:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-27 23:14:06 -0500

Seen: 163 times

Last updated: Jun 29 '14