Ask Your Question
1

rpm package version

asked 2014-07-03 11:41:53 -0500

jaksky gravatar image

updated 2014-07-04 02:17:57 -0500

Hi,

I am trying to install a specific version of rpm package from yum repository.

  package { 'jdk':
    ensure  =>'1.7.0_45',
    require => Yumrepo['internalYum']
  }

I am getting following error:

Error: Could not update: Failed to update to version 1.7.0_45, got version 1.7.0_45-fcs instead
Wrapped exception:
Failed to update to version 1.7.0_45, got version 1.7.0_45-fcs instead

Our internal repository contains just one artifact:

[root@tools~]# yum list jdk
jdk.x86_64                            2000:1.7.0_45-fcs                     @internalYum

Usually with yum repositories you can use less or more specific version and application manager resolve that. Do i need to provide some extra setting to get similar behaviour? Or is it bug or simply I have to provide fully specified version?

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-07-06 21:26:35 -0500

mbarr gravatar image

updated 2014-07-06 23:37:09 -0500

ramindk gravatar image

The fcs is actually part of the version. That's where your issue is. The x86_64 isn't, but the version is actually: 1.7.0_45-fcs.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-07-03 11:41:53 -0500

Seen: 701 times

Last updated: Jul 06 '14