Ask Your Question
0

[Solved] Puppet clients can not retrieve file from server

asked 2013-04-25 13:52:00 -0600

phthinh gravatar image

updated 2013-04-26 02:48:09 -0600

Hi, I'm a newbie. I got a 3 Ubuntu 12.04 VM, with 1 server and 2 agent, named server.my.puppet, client1.my.puppet and client2.my.puppet. Puppetmaster and puppet also 3.1.1.

On the server, I configured fileserver.conf like this

[files]
    path /etc/puppet/
    allow *.my.puppet

And puppet.conf like this

[main]
logdir=/var/log/puppet
vardir=/var/lib/puppet
ssldir=/var/lib/puppet/ssl
rundir=/var/run/puppet
factpath=$vardir/lib/facter
templatedir=$confdir/templates

[master]
autosign=true

On the agent, I configured

[main]
logdir=/var/log/puppet
vardir=/var/lib/puppet ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-04-25 15:32:43 -0600

Stefan gravatar image

You seem to structure your classes with modules (if you do not know what I mean, http://docs.puppetlabs.com/puppet/latest/reference/modules_fundamentals.html is probably worth reading), so

[files]
  path /etc/puppet/
  allow *.my.puppet

is generally not needed. factpath and templatedir should be the defaults so I'd suggest to remove them from your config entirely.

If you want to test your agent it is worth noting that the puppet agent uses syslog to report any changes, so you can check /var/log/messages for new entries. You can also run the puppet agent on the commandline ... (more)

edit flag offensive delete link more
0

answered 2013-04-26 02:43:37 -0600

phthinh gravatar image

So, I removed

[files]
  path /etc/puppet/
  allow *.my.puppet

on the fileserver.conf Then it worked.

Thank you !

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-25 13:52:00 -0600

Seen: 148 times

Last updated: Apr 26 '13