Ask Your Question
1

Can't install, ruby error message

asked 2013-05-01 13:25:45 -0500

samnyc gravatar image

Hi, I am on Redhat Enterprise 5.6 server. I did install Ruby. When I do ruby -v, I get this message. ruby 2.0.0p0 (2013-02-24 revision 39474) [x86_64-linux]

But when I try to install puppet. I am getting this error message.

rpm -ivh mcollective-common-2.2.3-1.el5.noarch.rpm warning: mcollective-common-2.2.3-1.el5.noarch.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 4bd6ec30 error: Failed dependencies: ruby is needed by mcollective-common-2.2.3-1.el5.noarch ruby(abi) >= 1.8 is needed by mcollective-common-2.2.3-1.el5.noarch rubygem(stomp) is needed by mcollective-common-2.2.3-1.el5 ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-05-01 16:24:01 -0500

Stefan gravatar image

RHEL5 comes with ruby 1.8.5 and puppetlabs has build a ruby 1.8.7 package (e.g. http://yum.puppetlabs.com/el/5Server/dependencies/x86_64/)because they plan to drop 1.8.5 support. I wonder where did you get 2.0.0p1?

You can see the supported ruby versions here: http://docs.puppetlabs.com/guides/platforms.html and I guess these dependencies are also expressed in the RPM specifications so you are unable to install the packages.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-01 13:25:45 -0500

Seen: 1,225 times

Last updated: May 01 '13