Ask Your Question
0

How do i edit the encoding used by facter?

asked 2014-07-10 07:35:27 -0600

robertapi gravatar image

updated 2014-07-10 07:36:38 -0600

Hi there,

i've been having a lot of trouble with the integration of windows clients into my puppet setup. It seems that the facter isnt encoding its timezone fact the way it should. It cant handle the "ä" propperly. timezone: "Mitteleuropõische Sommerzeit" what is really confusing, since the id fact is encoded correctly "id: "nt-autorität\x5csystem" in the same yaml file?

puppet doesnt seem to care so much, but as i'm trying to use TheForeman on top of my puppetsetup it seems to choke somehow if the timezone isnt encoded propperly. so i'm trying to fix that, google search came up with a bug report in which it was suggested i would edit the timezone.rb file on the windows client, to give him the UTF-8 flag so it would be correctly encoded, but for me that didnt change anything, the timezone value is still corrupt.

any ideas how to fix that?

greetings Robert

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2014-07-28 14:19:46 -0600

updated 2014-07-28 14:22:41 -0600

After some research it appears that Facter uses Time.now.zone, which is system locale dependent. The fix would need to go into Facter itself. There is already an issue filed that you can comment on, vote and/or watch https://tickets.puppetlabs.com/browse...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-07-10 07:35:27 -0600

Seen: 528 times

Last updated: Jul 28 '14