Ask Your Question
1

Reports Fail to Run & Excessive Pending Tasks in Console

asked 2013-05-07 17:57:38 -0600

updated 2013-05-07 17:58:07 -0600

Our puppet master and agents are running fine-- agents run without errors, configs are applied, but when I look in the Puppet Enterprise console none of the runs are getting reported, all nodes show unresponsive and the pending tasks is almost 200,000 and growing linearly. All reports stopped coming in on 3/1/2013.

I tried these 2 steps with no effect:

Restart dashboard workers:

/etc/init.d/pe-puppet-dashboard-workers restart

Optimize the database:

/opt/puppet/bin/rake \
-f /opt/puppet/share/puppet-dashboard/Rakefile \
RAILS_ENV=production \
db:raw:optimize

Any suggestions?

edit retag flag offensive close merge delete

Comments

What version of Puppet Enterprise? Also, try setting debug mode (uncomment the debug line in the master's config.ru, and also in the console's) and see what sort ...(more)

llowder gravatar imagellowder ( 2013-05-08 18:15:08 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-05-08 19:15:05 -0600

I'm using PE 2.6.1. I'm not clear on how to turn on debugging.

I did some more digging and found the init script for pe-puppet-dashboard-workers doesn't work so I started the delayed_job workers manually with:

sudo -u puppet-dashboard env RAILS_ENV=production /opt/puppet/share/puppet-dashboard/script/delayed_job -p dashboard -n 4 -m start

This started the background processing.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-07 17:57:38 -0600

Seen: 750 times

Last updated: May 08 '13