Ask Your Question
0

Invalid parameter create at /etc/././init.pp

asked 2013-05-13 00:06:11 -0600

phthinh gravatar image

Hi, I'm new to puppet and yesterday I wrote a module to install MPI, ATLAS and HPL, based on Bcarpio's Hadoop module. When I'm run puppet apply I found this error:

Error: Invalid parameter create at /etc/puppet/modules/hpl/manifests/init.pp:93 on node server.my.demo

While at 93th line, there's a '}'. I dont know why & how to fix this.

Any help will be appreciate :)

And here is my script. Line 93 is mark at }. Any help will be appreciate :)

#/etc/puppet/modules/hpl/manifests/init.pp

class hpl {

    require hpl::params

    group ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2013-05-13 01:40:45 -0600

lavaman gravatar image

That's simply a typo.

This:

exec { "install openmpi-${openmpi_version}": cwd => "${hpl::params::home}", create => "${hpl::params::home}/opemmpi/",

should be this:

exec { "install openmpi-${openmpi_version}": cwd => "${hpl::params::home}", creates => "${hpl::params::home}/opemmpi/",

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-13 00:06:11 -0600

Seen: 367 times

Last updated: May 13 '13