Puppet labs Training VM pe-postgress won't start

asked 2014-07-15 18:48:57 -0600

petepete gravatar image

Wanted to get started with Puppet. So I'm starting with the learning VM. I downloaded the vmware image for an esxi 5.1 server. Gave it 4 processors and 32 gb ram, Cent OS x64 vm. After some initial intro, the instructions it says to head to the web interface, but it the web server has a bland 500 Internal Server Error. I've reloaded (deleted the base image and uploaded the vmx again )the VM three times with the same results.

What I've found was pe-postgress fails to start

/var/log/messages:

Jul 15 21:40:45 learn puppet-agent[5492]: (/Stage[main]/Pepostgresql::Server/Service[postgresqld]) Failed to call refresh: Could not start Service[postgresqld]: Execution of '/sbin/service pe-postgresql start' returned 1 Jul 15 21:40:45 learn puppet-agent[5492]: (/Stage[main]/Pepuppetdb::Pe::Database/Pepostgresql::Tablespace[pe-puppetdb]/Pepostgresql_psql[Create tablespace 'pe-puppetdb']) Could not evaluate: Error evaluating 'unless' clause: 'psql: c$sql: could not connect to server: No such file or directory

[all the pe_postgresql tasks fail after this]

Jul 15 21:40:49 learn puppet-master[5552]: Unable to submit report: Error 500 while communicating with localhost on port 443:

/var/log/pr-postgresql/pgstartup.log:

LOG: could not bind IPv4 socket: Address already in use

HINT: Is another postmaster already running on port 5432? If not, wait a few seconds and retry.

FATAL: could not create shared memory segment: Invalid argument

DETAIL: Failed system call was shmget(key=5432001, size=3903717376, 03600).

HINT: This error usually means that PostgreSQL's request for a shared memory segment exceeded your kernel's SHMMAX parameter. You can either reduce the request size or reconfigure the kernel with larger SHMMAX. To reduce the request $ If the request size is already small, it's possible that it is less than your kernel's SHMMIN parameter, in which case raising the request size or reconfiguring SHMMIN is called for. The PostgreSQL documentation contains more information about shared memory configuration.

following the breadcrumbs I took a look at /etc/sysctl.conf

kernel.msgmnb = 65536

kernel.msgmax = 65536

kernel.shmmax = 7918845952

kernel.shmall = 268435456

Finally, after a desperation reboot I see on the web interface

Web application could not be started could not connect to server: Connection refused

I must be doing something wrong with this training VM, could someone please point me in the correct direction?

Thanks, Pete

edit retag flag offensive close merge delete