Ask Your Question
0

Question : Installation of a CA server

asked 2014-07-16 02:18:37 -0600

thampi_lakshmi gravatar image

Was trying to install CA server with $ sudo puppet master --verbose --no-daemonize

But is getting this error

root@ubuntu:/etc/puppet# sudo puppet master --verbose --no-daemonize Warning: Setting templatedir is deprecated. See http://links.puppetlabs.com/env-setti... (at /usr/lib/ruby/vendor ruby/puppet/settings.rb:1095:in `issuedeprecations') Notice: Starting Puppet master version 3.6.2 Error: Could not run: Address already in use - bind(2)

any help to solve this would be appreciated

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-07-16 03:41:29 -0600

AdamB gravatar image

Have you tried running with a different port?

edit flag offensive delete link more
0

answered 2014-07-16 02:51:40 -0600

thampi_lakshmi gravatar image

Modifying the question above, The error got modified into

Error: Could not run: Address already in use - bind(2) when run as a super user. But still needs suggestions on why this error?

edit flag offensive delete link more

Comments

I am having that exact same problem. Where do I go from there to get the correct output?

mikel gravatar imagemikel ( 2014-09-29 16:14:32 -0600 )edit
0

answered 2014-07-16 03:04:25 -0600

mld gravatar image

Have a look if something is already running on port 8140:

$ sudo netstat -ltnp

edit flag offensive delete link more

Comments

Nothing is running on 8140 root@ubuntu:/etc/puppet/modules# sudo netstat -ltnp Active Internet connections (only servers) Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 4192/apache2 tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 969/cupsd tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 4192/apache2 tcp 0 0 0.0.0.0:8140 0.0.0.0:* LISTEN 4192/apache2 tcp6 0 0 ::1:631 :::* LISTEN 969/cupsd

thampi_lakshmi gravatar imagethampi_lakshmi ( 2014-07-17 01:04:40 -0600 )edit

yes seems like, 8140

thampi_lakshmi gravatar imagethampi_lakshmi ( 2014-07-17 01:06:57 -0600 )edit

It turns out that apache2 server is running on 8140 port. was trying to stop the same >>> apache2ctl -k stop - is the command we used Error which we received : apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName httpd (pid 4192?) not running What should be done then ?

thampi_lakshmi gravatar imagethampi_lakshmi ( 2014-07-17 02:35:56 -0600 )edit

It seems you have tried to install passenger/unicorn/thin or something like them to run under apache instead of the built in webrick. In that case you shouldn't run the puppetmaster at all, since it's run through apache. Try starting out with a clean environment for the guide you are following.

mld gravatar imagemld ( 2014-07-18 04:15:00 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-16 02:18:37 -0600

Seen: 2,253 times

Last updated: Jul 16 '14