Ask Your Question
0

can't restart puppet in RHEL 6.3

asked 2014-07-17 16:48:30 -0600

chizou gravatar image

updated 2014-07-17 16:49:01 -0600

the /etc/init.d/puppet and /etc/init.d/puppetmaster scripts can't correctly restart the services. it seems like the /var/run/puppet/{master,agent}.pid files aren't being created correctly. Is anyone experiencing this in a RHEL6 based system?

puppet --version is 3.6.2

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-07-20 21:05:32 -0600

mapa3m gravatar image

Need more info.

Are the processes being started even thought the pid files aren't being created?

Check /var/log/messages and /var/log/puppet/*log for related messages, and make sure that the user Puppet is being started as has write permissions to /var/lib/puppet (I assume you used the RPM to install and kept the default directories).

edit flag offensive delete link more

Comments

thanks for the response, but as it turns out, it's a bug in puppet. i've answered my own question with more info if you'd like to see.

chizou gravatar imagechizou ( 2014-07-20 23:27:57 -0600 )edit
0

answered 2014-07-20 23:28:14 -0600

chizou gravatar image

updated 2014-07-20 23:31:53 -0600

as it turns out, it's a bug in puppet https://tickets.puppetlabs.com/browse...

although out of the box, 3.6.2 works, the run_dir variable alone still doesn't work. you have to modify it in your puppet config file and at least the init script too. the init script specifies where to look for a pid file and it has to all match up. i didn't bother trying to get it to work by deviating from the default so i can't verify how to make it work other than don't change anything out of the box.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-17 16:48:30 -0600

Seen: 69 times

Last updated: Jul 20 '14