Ask Your Question
0

PE 3.3 on RHEL 7 - Could not find terminus console for indirection node

asked 2014-07-22 09:39:44 -0500

Seb gravatar image

With a fresh install (monolithic) of PE 3.3 on RHEL 7 I'm currently getting the following error:

...
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/git_html_path.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/git_version.rb
Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Failed when searching for node puppet.***: Could not find terminus console for indirection node
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

when running on the master node:

puppet agent --test

The console.rb file exists on the disk: /opt/puppet/share/puppet/modules/puppet_enterprise/lib/puppet/indirector/node/console.rb

Version: 3.6.2 (Puppet Enterprise 3.3.0)

Not that Puppet is even getting as far as contacting the console, but I can access it through a web browser and the first 4 test runs appeared in the console, but not they don't (nothing has changed). I can't work out why the console terminus cannot be found, or even where Puppet is looking (apparently in the wrong place)

Ruby version: ruby 2.0.0p353 (2013-11-22) [x86_64-linux]

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-07-22 13:43:27 -0500

llowder gravatar image

If this was an upgrade, and you made manual edits to your puppet.conf, it may not have been updated properly by the installer.

Please check that you have the following lines:

reports = console,puppetdb
node_terminus = console

If you have a reporturl that is no longer needed and can be removed.

Restart the master (sudo service pe-httpd restart) after making the changes.

edit flag offensive delete link more

Comments

It was a new install on a clean RHEL 7 box (i.e. nothing else installed) and both those settings are configured as above.

Seb gravatar imageSeb ( 2014-07-23 03:30:26 -0500 )edit

Any breakthrough ..?? i am getting the same issue ,i am installing puppet 4.1 (ruby-2.1) from source code.

Mohan Sanagapalli gravatar imageMohan Sanagapalli ( 2015-06-11 07:57:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-22 09:39:44 -0500

Seen: 1,260 times

Last updated: Jul 22 '14