Ask Your Question
0

question: Win 7 Puppet agent : Error: Could not request certificate: getaddrinfo: No such host is known

asked 2014-07-25 05:42:20 -0500

thampi_lakshmi gravatar image

updated 2014-07-25 07:27:49 -0500

llowder gravatar image

Error: Could not request certificate: getaddrinfo: No such host is known

This error is shown when trying to connect client in windows 7 to Server which is a unix system

edit retag flag offensive close merge delete

Comments

@thampi_lakshmi Oops, sorry. Completely missed the Windows part. There's a "server" option that can explicitly tell the agent the hostname of the master. Can you try using that?

Louis gravatar imageLouis ( 2014-07-25 06:52:28 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
3

answered 2014-07-25 07:41:47 -0500

llowder gravatar image

This error means that the agent node cannot resolve the master hostname.

Verify that the server line in your agent's puppet.conf is an actual resolvable name of your master. By default, the value is server = puppet.

Once you have verified that is correct, make sure that the agent can resolve the name in the server line, and then you should be able to do a successful puppet run.

edit flag offensive delete link more

Comments

1

This is exactly what my problem was when I encountered that error message. Ensuring my config had the correct server, and that my agent had a route to the master (and a reverse route) fixed my issue.

DarylW gravatar imageDarylW ( 2015-09-05 15:33:21 -0500 )edit
0

answered 2015-09-04 14:28:20 -0500

mike.r gravatar image

Having same issue, puppet 3.8.2, master is on Lubuntu, puppet node is win7

master has puppet cert accepted, i can resolve master from node via ping and vice versa,

Node's puppet.conf has [main] server=puppetmaster

when I run 'puppet agent --test --debug --verbose' Debug: creating new connection for https://puppet:8140

Its using the default master 'puppet' name, but my master is called 'puppetmaster'

where else can i look on node to change the default name? Btw, I have another node (Centos) and it works w/o issues.

edit flag offensive delete link more

Comments

Have you tried the fully qualified domain name? Or tried doing 'ping puppetmaster'? to see if it goes to your master server?

SKasai gravatar imageSKasai ( 2015-09-05 18:29:16 -0500 )edit
0

answered 2014-09-22 20:10:46 -0500

I have same problem(similar?). I installed puppet on windows and it shows me: C:/Ruby21-x64/lib/ruby/2.1.0/net/http.rb:922:in `connect': SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (Faraday::SSLError) it tries to connect to forgeapi.puppetlabs.com

and puppet agent --test print this Error: Could not request certificate: getaddrinfo: No such host is known. Exiting; failed to retrieve certificate and waitforcert is disabled

is there a way to solve this?

edit: maybe I posted it wrong place. I found this issue: https://ask.puppetlabs.com/question/2... and https://ask.puppetlabs.com/answers/25... and I have same problem with forgeapi.puppetlabs.com

openssl s_client -showcerts -connect forgeapi.puppetlabs.com:443 shows Verify return code: 20 (unable to get local issuer certificate)

I've tried adding https://www.geotrust.com/resources/rootcertificates/certificates/GeoTrustGlobal_CA.pem into windows certificates, but it doesnt seem to help

edit flag offensive delete link more

Comments

I would reinstall the client and during the installation, make sure to set the puppet server with the appropriate DNS name. Be sure to remove any folders under C:\Program Files\Puppet Labs or C:\ProgramData\Puppet Labs before you install the new client.

johnnyb04 gravatar imagejohnnyb04 ( 2015-09-08 07:42:26 -0500 )edit
0

answered 2016-03-21 11:05:31 -0500

aklotz gravatar image

I had the same error as OP. One of the helpful comments I found was to set the --debug --verbose flags when I ran Puppet_Interactive. The log output showed me that puppet agent was looking for files in my C:\users\ajklotz.puppet folder instead of C:\programdata\puppet*. The whole thing started because I did not start the Puppet Shell using the 'Run As Administrator' option.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-07-25 05:42:20 -0500

Seen: 3,733 times

Last updated: Sep 04 '15