Ask Your Question
0

Failure install puppet-server.

asked 2014-07-31 14:38:14 -0600

tek0011 gravatar image

I am trying to install a puppet server on CentOS 6.5 and keep getting the same error:

--> Finished Dependency Resolution
Error: Package: 1:ruby-shadow-2.2.0-2.el7.x86_64 (puppetlabs-deps)
           Requires: libruby.so.2.0()(64bit)
Error: Package: ruby-augeas-0.4.1-3.el7.x86_64 (puppetlabs-deps)
           Requires: libruby.so.2.0()(64bit)
Error: Package: puppet-3.6.2-1.el7.noarch (puppetlabs-products)
           Requires: systemd
Error: Package: ruby-augeas-0.4.1-3.el7.x86_64 (puppetlabs-deps)
           Requires: ruby(release) = 2.0.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Any ideas how to resolve this?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-07-31 15:30:47 -0600

ramindk gravatar image

updated 2014-08-01 13:02:08 -0600

It's trying to install the el7 packages. You're probably pointing to the wrong repo.

You installed the el7 repo from here. Remove it and install the el6 repo.

You might also be missing the EPEL repo which will have certain dependencies RHEL based installs need IIRC. Try adding it and see if you get farther.

edit flag offensive delete link more

Comments

k. I forced the el6 repo to over write. Now I am getting: --> Finished Dependency Resolution Error: Package: puppet-3.6.2-1.el7.noarch (puppetlabs-products) Requires: systemd Error: Package: ruby-augeas-0.4.1-3.el7.x86_64 (puppetlabs-deps) Requires: ruby(release) = 2.0.0

tek0011 gravatar imagetek0011 ( 2014-08-01 12:57:04 -0600 )edit

this ended up resolving it: yum clean all rpm --rebuilddb yum update

tek0011 gravatar imagetek0011 ( 2014-08-01 13:24:46 -0600 )edit
0

answered 2014-08-01 08:44:15 -0600

tek0011 gravatar image

Thanks for the reply, however, I am not a Linux guy. Not sure how to resolve that.

edit flag offensive delete link more

Comments

resolved the above, new error --> Finished Dependency Resolution Error: Package: puppet-3.6.2-1.el7.noarch (puppetlabs-products) Requires: systemd Error: Package: ruby-augeas-0.4.1-3.el7.x86_64 (puppetlabs-deps) Requires: ruby(release) = 2.0.0

tek0011 gravatar imagetek0011 ( 2014-08-01 09:40:13 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-07-31 14:38:14 -0600

Seen: 3,101 times

Last updated: Aug 01 '14