Ask Your Question
0

Not authorized to call search on /file_metadata/files

asked 2014-08-18 13:49:55 -0500

Tangaloor gravatar image

Using PE 3.3.1 on the master (just upgraded during attempted resolutions) Using PE 3.2.3 agents

One agent inside LAN (192.168.34.0/24) One agent going through Tomato router NAT forwarding

I've been searching for days on this issue, yielding many things to try with auth.conf and fileserver.conf and the actual URLs used in the manifests. Nothing I have tried yet has resolved this issue. Here are the relevant configuration sections.

auth.conf:

 path /file_metadata/files
 auth yes
 allow /^(.+\.)?wilsonet.us$/
 allow /^(.+\.)?pve-inc.com$/
 allow_ip 192.168.34.0/24

 path /file_content/files
 auth yes
 allow /^(.+\.)?wilsonet.us$/
 allow /^(.+\.)?pve-inc.com$/
 allow_ip 192.168.34.0/24

 path ~ ^/file_(metadata|content)s?/files/
 auth yes
 allow /^(.+\.)?wilsonet.us$/
 allow /^(.+\.)?pve-inc.com$/
 allow_ip 192.168.34.0/24

 path /file
 auth yes
 allow *

fileserver.conf:

[files]
path /etc/puppetlabs/puppet/files
allow *

manifest snippet:

        file { "/home/${username}":
            ensure  => directory,
            owner   => $home_owner,
            group   => $home_group,
            #mode    => 644, # Cannot apply mode, or it will change ALL files
            recurse => true,
            replace => true,
            force   => true,
            ignore  => '.git',
            source  => [
                "puppet:///files/users/home/managed/host/${username}.$fqdn",
                "puppet:///files/users/home/managed/host/${username}.$hostname",
                "puppet:///files/users/home/managed/domain/${username}.$domain",
                "puppet:///files/users/home/managed/env/${username}.$environment",
                "puppet:///files/users/home/managed/user/${username}",
                "puppet:///files/users/home/managed/skel",
            ],
            require   => User["${username}"],
        }

The error occurs on the first source.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-07-28 08:08:09 -0500

Hi,

Are you still faced with this issue?

I've often seen this issue when the files under your fileserver.conf path (/etc/puppetlabs/puppet/files in your case) don't have the correct execute permissions for the user the puppet master is running as.

Cheers, Josh

edit flag offensive delete link more
0

answered 2014-08-18 17:12:59 -0500

jzimmerman gravatar image

Just to get simple stuff out of the way... have you tried to restart the puppet master? service pe-httpd restart?

edit flag offensive delete link more

Comments

Yes. Basically every time I adjusted auth.conf or fileserver.conf.

Tangaloor gravatar imageTangaloor ( 2014-08-26 09:56:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-18 13:49:55 -0500

Seen: 526 times

Last updated: Jul 28 '15