Ask Your Question
0

whitspace on ini_setting key_val_seperator

asked 2014-08-25 04:16:16 -0500

lgbff gravatar image

updated 2014-08-27 00:23:53 -0500

Hi,

I'll change the /etc/ssh/sshdconfig file with inisetting with this config code:


  #Banner für sshd
  ini_setting { 'sshd_banner':
        ensure => present,
        path => '/etc/ssh/sshd_config',
        section => '',
        key_val_seperator => '',
        setting => 'Banner',
        value => '/etc/issue.net',
  }
The key seperator must an whitspace, but the puppet agent generat a issue:

Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Invalid parameter keyvalseperator on Inisetting[sshdbanner] at /etc/puppet/environments/dev/manifests/classes/motd.pp:59 on node server Warning: Not using cache on failed catalog Error: Could not retrieve catalog; skipping run

What can i do?

thx Karsten

edit retag flag offensive close merge delete

Comments

i change the code Block with backslash befor '_', i hope that's right displayed ;-)

lgbff gravatar imagelgbff ( 2014-08-27 00:22:53 -0500 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2014-08-31 08:36:48 -0500

cristaldo gravatar image

I think that the key separator param just permit "=" I have tried to use ":" but the module does not accept!

edit flag offensive delete link more
0

answered 2014-08-26 12:32:19 -0500

WhatsARanjit gravatar image

The parameter you want is actually: keyvalseparator

edit flag offensive delete link more

Comments

Your mean 'keyvalseparator'? This generate a issue:


Invalid parameter keyvalseperator on Ini_setting[sshbanner]
I think the parameter key_val_separator is rigth ;-), but a whitspace is not admit.... any other hints?

lgbff gravatar imagelgbff ( 2014-08-27 00:30:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-08-25 04:16:16 -0500

Seen: 165 times

Last updated: Aug 31 '14