Ask Your Question
0

How to keep server from applying manifest ?

asked 2013-05-16 02:35:50 -0500

phthinh gravatar image

updated 2013-05-16 02:43:31 -0500

I know that the server is a default node. I want to apply jobs for some nodes. And if I dont place

node default { include command }

It will display message:

Error: Could not find default node or by name with 'server.my.demo, server.my, server' on node server.my.demo

Is there anyway to keep server from applying any manifest ?

Any help will be greatly apprieciate ~ :D

edit retag flag offensive close merge delete

Comments

1

The default node is used when no other node definition matched the agents hostname. If one of the agents requesting a catalog has no node definition it will fallback to ...(more)

Daniel gravatar imageDaniel ( 2013-05-16 02:46:16 -0500 )edit

Thank you ! It worked.

phthinh gravatar imagephthinh ( 2013-05-17 00:27:27 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-16 13:59:29 -0500

lavaman gravatar image

The error is telling you the master could not compile a catalog for the host, so it is applying none. That error indicates your desired outcome.

If you don't want to apply a manifest, why do you have the server running puppet at all?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-16 02:35:50 -0500

Seen: 346 times

Last updated: May 16 '13