Ask Your Question
0

Puppet server Upgradation

asked 2014-08-31 21:31:33 -0500

KK gravatar image

I have Puppet server 2.6.4 version manually installed using rpm. I want to safely upgrade it to latest 3.6 version by installing Puppetlabs repo. Same way Puppet clients are installed manually using rpm. How can I rollback to current version if something breaks or Backup Current Installation ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-02 08:10:38 -0500

mapa3m gravatar image

I'm not sure 3.6.x master would even be compatible with 2.6.x clients (or vice versa). However, if you can manage to resolve the dependency chain needed to go from 2.6.4 to 3.6.x, you should be able to roll back if needed using the same RPMS (using YUM for this is immensely helpful).

A bigger issue to consider is that Puppet 2.6.x code will almost definitely break or misbehave on 3.6, so lots and lots of testing is in order.

edit flag offensive delete link more

Comments

We have tested. It worked well.

KK gravatar imageKK ( 2014-09-06 10:26:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-31 21:31:33 -0500

Seen: 91 times

Last updated: Sep 02 '14