Ask Your Question
0

How to install specific version of puppet using Puppetlabs repo

asked 2014-09-06 10:24:47 -0500

KK gravatar image

updated 2014-09-06 10:28:01 -0500

Hi everyone

My puppet server and clients are on version 2.7.25. I am going to upgrade puppet server using puppelabs repo. According to puppetlabs repo Puppet packages are going to upgrade on latest 3.7 version. How can I upgrade them to specific old versions (like 3.6.1 release ) ?

edit retag flag offensive close merge delete

Comments

1

Which operating system?

domcleal gravatar imagedomcleal ( 2014-09-07 08:51:33 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-09-12 05:40:20 -0500

devops gravatar image

Refer - http://www.puppetcookbook.com/posts/l... Instead of latest, give the appropriate version here.

Example , for jenkins i've used like this package {'jenkins': ensure => "1.575-1.1", }

Ex - i have used yum directly like this

yum install puppet-2.7.26

You can try yum upgrade puppet-3.1.6

edit flag offensive delete link more
0

answered 2014-09-12 06:41:41 -0500

The following instructions apply to Ubuntu Server 14.04 LTS "Trusty Tahr" and are what I used to install and lock in v3.6.2 on our newest server:

 wget https://apt.puppetlabs.com/puppetlabs-release-trusty.deb
 sudo dpkg -i puppetlabs-release-trusty.deb
 sudo apt-get update;
 apt-get install -y --install-suggests puppet-common=3.6.2-1puppetlabs1
 sudo apt-mark hold puppet-common
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-09-06 10:24:47 -0500

Seen: 3,946 times

Last updated: Sep 12 '14