Ask Your Question
0

puppet node deactivate fails with 407 Proxy Authentication required [closed]

asked 2014-09-07 21:28:27 -0500

Puppet Enterprise 3.3.1 on CentOS 6.5

I am trying to run puppet node deactivate on a node and it fails with 407 Proxy Authentication required.

Output of puppet cert list --all (redacted)

  • "testinstance2.racqgroup.local" (SHA256) <redacted>

puppet node deactivate testinstance2.racqgroup.local Error: Failed to submit 'deactivate node' command for testinstance2.racqgroup.local to PuppetDB at puppet-staging.racqgroup.local:8081: 407 "Proxy Authentication Required" Error: Try 'puppet help node deactivate' for usage

The system is not configured with a proxy of any kind. I don't understand what proxy it would touch when running puppet node deactivate.

Has anyone seen this happen before and can help?

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant by rainynight65
close date 2014-09-07 22:23:07.909310

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-09-07 22:22:58 -0500

Never mind. A bit of digging and I found an errant proxy configuration that shouldn't have been on the server. My own fault for doing stuff and then forgetting about it.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-09-07 21:28:27 -0500

Seen: 349 times

Last updated: Sep 07 '14