Ask Your Question

Prevent First Run - Puppet Install

asked 2014-09-09 14:08:33 -0600

tek0011 gravatar image

updated 2014-09-15 10:51:03 -0600

Is there a way in Windows to prevent the first run that auto-executes after you install?

edit retag flag offensive close merge delete


See joshc's answer. That's the correct way to not turn on the agent automatically.

rob gravatar imagerob ( 2014-09-15 10:14:13 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2014-09-09 14:20:27 -0600

joshc gravatar image

updated 2014-09-15 15:28:47 -0600

Set the MSI property PUPPET_AGENT_STARTUP_MODE=Manual during installation. See for more information.

edit flag offensive delete link more


You may want to fix your [link]( as ask seems to fall over on links that have multiple underscores, etc.

rob gravatar imagerob ( 2014-09-15 10:11:37 -0600 )edit

Yep, it's the anchor that causes problems, and it can't be escaped, see

joshc gravatar imagejoshc ( 2014-09-15 11:50:11 -0600 )edit

It can be escaped if you use [ name of link ] ( actual link) <- markdown

rob gravatar imagerob ( 2014-09-15 14:31:50 -0600 )edit

ah, thanks for the tip!

joshc gravatar imagejoshc ( 2014-09-15 15:29:08 -0600 )edit

answered 2014-09-10 13:14:07 -0600

tek0011 gravatar image

I am trying to set it up so that the service will automatically run, but that it will not automatically execute a puppet agent --test right after install.

Our users want the service to be Automatic as it is default, but they want to be able to watch the logging on the very first time they run it. I suppose I could just add some lines to tell puppet to turn itself to automatic?

That way when they install it , it will get installed as Manual, so they can watch it run the first time through, and then when they initiate the first run, it would then set puppet to Auto. Think that would be the best course of action?

edit flag offensive delete link more


Yes, you can manage puppet's service using puppet. So the following will change puppet's service type from manual to automatic:

service { 'puppet':
  ensure => 'running',
  enable => 'true',

joshc gravatar imagejoshc ( 2014-09-15 11:53:05 -0600 )edit

answered 2014-09-10 04:13:49 -0600

GlennSarti gravatar image

I did have an issue doing that, but there's a simple workaround. Not sure if it's been fixed in later versions of the Puppet Agent install. As my ticket is still open, I assume not.

Workaround; Run MD "%PROGRAMDATA%\PuppetLabs\puppet\var\state\graphs" after you install the puppet agent.

edit flag offensive delete link more


This issue is still open, but only occurs if you set the service type to Manual, and then run

puppet apply
prior to running
puppet agent

joshc gravatar imagejoshc ( 2014-09-15 12:00:35 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-09-09 14:08:33 -0600

Seen: 255 times

Last updated: Sep 15 '14