Stange puppet parsing error in versions prior to 3.4

asked 2014-09-25 23:31:11 -0600

liamjbennett gravatar image

updated 2014-09-26 13:36:45 -0600

I am testing some of my modules against old versions and I see the following error appear consistently on all versions prior to 3.4.0

Puppet::Error:
    expected next element in array at '
        "dependencies": ['! at line 4 on node liams-macbook-pro.local

I also occasionally see this almost identical error under the same test scenarios:

Puppet::Error:
    expected next element in array at ',
        "requirements": '! at line 4 on node liams-macbook-pro.local

This even seems to occur even on manifests with a single class or definition with zero resources. The error is pretty unapproachable in terms on debugging.

Has anyone seen this sort of error before?

edit retag flag offensive close merge delete

Comments

Seems like its a PSON parser issue - how are you testing when this happens, is there a puppet master involved? Is the master and agent running the same version?

jonn gravatar imagejonn ( 2014-09-27 05:13:22 -0600 )edit