Ask Your Question
0

Failed to load library msgpack

asked 2014-09-26 16:51:57 -0500

azweb gravatar image

I see the following error when I run puppet agent --onetime --verbose --debug

Info: Loading facts Debug: Failed to load library 'msgpack' for feature 'msgpack' Debug: Puppet::Network::Format[msgpack]: feature msgpack is missing

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-09-29 17:17:50 -0500

cprice404 gravatar image

Also, if you are seeing this on your master frequently, and you are running Puppet 3.7.0+, you might want to set the new always_cache_features setting under [master] to true. This will cause the master to only check for msgpack one time (per ruby process), and can result in a significant performance improvement.

edit flag offensive delete link more

Comments

I am seeing a bazillion of these on a few agents. Does the "always_cache_features" setting work on the agent side ? Is there any way to turn it off until it graduates from experimental status ?

LinuxDan gravatar imageLinuxDan ( 2014-12-17 10:10:14 -0500 )edit

Just for others' information. Setting `always_cache_features` to true only dismisses the `Failed to load library 'msgpack' for feature 'msgpack'` message, `feature msgpack is missing` will still exist. But it's no harm because master only tries to load `msgpack` once.

zsl gravatar imagezsl ( 2015-08-18 23:51:14 -0500 )edit
0

answered 2014-09-27 10:17:47 -0500

jonn gravatar image

I think this is related to the experimental support for msgpack as a protocol for master-server communication. You can install the msgpack gem if you'd like to try the feature out, otherwise this message can be ignored.

Further info is available here.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-09-26 16:51:57 -0500

Seen: 10,665 times

Last updated: Sep 29 '14