Ask Your Question
0

Question on Installing CA server

asked 2014-09-29 15:32:16 -0500

mikel gravatar image

updated 2014-09-29 15:54:43 -0500

I just tried running this command:

puppet master --verbose --no-daemonize

to configure certficates on the Puppet master server. I ran that command as the root user. I wound up getting this error message:

Notice: Starting Puppet master version 3.7.1 Error: Could not run: Address already in use - bind(2)

What would be the reason why I am getting that error and what could I do to get the proper output?

According to the instructions I am supposed to see "the CA certificate and the puppet master certificate, with the appropriate DNS names included. Once it says Notice: Starting Puppet master version <version>, type ctrl-C to kill the process." One more thing that I want to mention is that ]# service puppet status puppet (pid 60179) is running... ]# service puppetmaster status puppet dead but pid file exists Is the above what I am supposed to see in my server that is acting as the puppet master? Is that the correct output? Any help would be greatly appreciated.

edit retag flag offensive close merge delete

Comments

I just did that netstat command and got this output: netstat -aNp | grep 8140 tcp 0 0 *:8140 *:* LISTEN 2267/httpd Is this suppose to be the correct output?

mikel gravatar imagemikel ( 2014-09-30 11:01:41 -0500 )edit

Why do I have to stop running puppet master to run the netstat command? Isn't puppet master supposed to run? If not what are the correct steps to take afterwards?

mikel gravatar imagemikel ( 2014-09-30 14:52:57 -0500 )edit

My apologies - you have to stop the master before you can run `puppet master --verbose --no-daemonize` because that command starts up a new instance of the master.

llowder gravatar imagellowder ( 2014-10-01 07:52:47 -0500 )edit

So what would be the command to stop master?

mikel gravatar imagemikel ( 2014-10-01 11:45:35 -0500 )edit

Keep in mind too that this is my first time ever configuring a puppet master server.

mikel gravatar imagemikel ( 2014-10-01 11:45:57 -0500 )edit

1 Answer

Sort by ¬Ľ oldest newest most voted
0

answered 2014-09-30 07:55:40 -0500

llowder gravatar image

The puppet service is the agent daemon, not the master. If you are getting could not bind, then check netstat to see what is using port 8140.

For example:

# netstat -aNp | grep 8140
tcp        0      0 *:8140                      *:*                         LISTEN      11299/pe-httpd.work

You may already have the master running, or something else is using that port.

edit flag offensive delete link more

Comments

If you have a master currently running - and it looks like you have one behind apache httpd/passenger, you'll have to stop it before you run that command.

llowder gravatar imagellowder ( 2014-09-30 14:33:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-29 15:32:16 -0500

Seen: 1,131 times

Last updated: Sep 30 '14