php5 disabled hetzner/roundcube and puppetlabs/apache

asked 2014-10-01 03:51:24 -0600

murray gravatar image

updated 2014-10-01 11:25:42 -0600

ramindk gravatar image

Hi, I am using the hetzner/roundcube module which uses puppetlabs/apache to install and configure apache. My php5 is installed but not enabled. If I manually do a "a2enmod php5" php works and I get to the Roundcube page but I need it working from puppet by default. I am using Debian Wheezy. The relevant part of my puppet manifest is below. I hope someone can help? Thanks, Murray

class {roundcube::webservice::apache:
      apache_port => '443',
      mpm_module => 'prefork',
      redirect_to_ssl => true,
      ssl => true,
      ssl_cert => '/etc/roundcube/*.example.com.crt',
      ssl_key => '/etc/roundcube/*.example.com.key',
      ssl_ca => '/etc/roundcube/comodo_high_assurance_ca.crt',
  }

  class {roundcube::roundcubeweb:
      roundcube_backend => "mysql",
      force_https => true,
      database_host => 'webmail-db.example.com',
      database_port => '3306',
      database_name => 'roundcube',
      database_username => 'root',
      database_password => 'xxxxx',
      #database_ssl => '',
  }
edit retag flag offensive close merge delete

Comments

Where's the part where you install php5?

ramindk gravatar imageramindk ( 2014-10-01 11:26:18 -0600 )edit