Ask Your Question
0

biemond/jdk7 not working

asked 2014-10-01 06:09:31 -0500

patrik gravatar image

updated 2014-10-10 19:11:14 -0500

nanliu gravatar image

I'm new to puppet and have installed the biemond-jdk7 module. In the install7.pp I just changed the $version and $fullVersion

define jdk7::install7 (
  $version                   = '7u67',   #changed by patrik
  $fullVersion               = 'jdk1.7.0_67',   #changed by patrik
  $javaHomes                 = '/usr/java',
  $x64                       = true,
  $alternativesPriority      = 17065,
  $downloadDir               = '/install',
  $cryptographyExtensionFile = undef,
  $urandomJavaFix            = true,
  $rsakeySizeFix             = false,  # set true for weblogic 12.1.1 and jdk 1.7 > version 40
  $sourcePath                = 'puppet:///modules/jdk7/',
) {

In the jdk7 module path I created the files directory and did put the jdk-7u67-linux-x64.tar.gz file there. in the puppet enterprise console I added the jdk7 class and then did change the default group to include the jdk7 class. In the LiveManagement I did a runonce, but I don't see the java version getting installed. I checked with grep all logs under /var/log for anything comming up with jdk7 but there were no errors. I also tried on the agent node to run puppet agent --test but there is also no error:

$ puppet agent --test
Info: Retrieving plugin
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/concat_basedir.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/custom_auth_conf.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/facter_dot_d.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/ip6tables_version.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/iptables_persistent_version.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/iptables_version.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/pe_build.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/pe_postgres_default_version.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/pe_puppetdb_server_status.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/pe_version.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/platform_tag.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/puppet_vardir.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/root_home.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/staging_http_get.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/windows.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/oracle_database_homes.rb
Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/oracle_middleware_homes.rb
Info: Caching catalog for adzh-srlt-qa01.intern.cube.ch
Warning: The package type's allow_virtual parameter will be changing its default value from false to true in a future release. If you do not want to allow virtual packages, please explicitly set allow_virtual to false.
   (at /opt/puppet/lib/ruby/site_ruby/1.9.1/puppet/type.rb:816:in `set_default')
Info: Applying configuration version '1412159270'
Notice: Finished catalog run in 2.92 seconds

all machines are running rhel 7.

Has anyone an idea why java is not installed by the agents or where I could have another look what's going wrong?

many thanks patrik

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-10 19:15:25 -0500

nanliu gravatar image

updated 2014-10-10 19:15:50 -0500

This is a define type, not a puppet class, so you won't be able to add it directly in console. You can write a wrapper class which declares a resources, and you should not edit the define type defaults so something like:

class my_jdk {
    jdk7::install7{ 'jdk1.7.0_51':
        version                   => "7u51" ,
        fullVersion               => "jdk1.7.0_51",
        alternativesPriority      => 18000,
        x64                       => true,
        downloadDir               => "/data/install",
        urandomJavaFix            => true,
        rsakeySizeFix             => true,                          <!--
        cryptographyExtensionFile => "UnlimitedJCEPolicyJDK7.zip",  <!---
        sourcePath                => "/software",
    }
}

And you can include my_jdk via PE console.

edit flag offensive delete link more

Comments

Thanks nanliu, that worked just fine.

patrik gravatar imagepatrik ( 2014-10-14 01:25:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-01 06:09:31 -0500

Seen: 148 times

Last updated: Oct 10 '14