Ask Your Question
0

Manifests are ignored after upgrade

asked 2014-10-15 08:49:40 -0600

robrwo gravatar image

updated 2014-10-15 08:56:33 -0600

We recently upgraded to 3.6.2 (Puppet Enterprise 3.3.2) and found that Puppet runs very quicky: in 1-2 seconds for most servers. As it turns out, this is because Puppet is completely ignoring the manifests.

Running sudo puppet config print shows environment variables with the correct paths.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-16 08:52:01 -0600

robrwo gravatar image

To fix this, we did the following:

  • in puppet.conf, basemodulepath is just set to the default "/opt/puppet/share/puppet/modules". (We removed the additional "$confdir/environments/$environment/modules")

  • we removed environment.conf

This seems to have fixed it, but there are other problems (to be noted in another question).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-15 08:49:40 -0600

Seen: 35 times

Last updated: Oct 16 '14