Restart resets node-ttl in database.ini

asked 2014-10-18 00:29:08 -0500

tle gravatar image

I want to automatically deactivate nodes that have been unresonsive for 24hours.
As per: https://docs.puppetlabs.com/puppetdb/...

I have set the following in /etc/puppetlabs/puppetdb/conf.d/database.ini

[database]
node-ttl = 24h

When i restart the pe-puppetdb service the settings seem to be applied and unresponsive nodes are deregistered however the file (database.ini) reverts its settings to:

[database]
node-ttl = 7d

How can i persist this setting?

edit retag flag offensive close merge delete