Ask Your Question
0

Port 8139 not opened when running as a Windows Service

asked 2014-10-24 06:24:41 -0500

ArmanCastell gravatar image

Hi, I am running my puppet agent (version 3.7.0) on Windows 7 x64. The master is running on Ubuntu 14.04 with Foreman. I have enabled the run puppetbutton.

On the agent, I added the auth.conf with the required permissions, and also an empty namespaceauth.conf to C:\ProgramData\PuppetLabs\puppet\etc.

However, when I start the agent as a Service, I can't trigger a run (connection failed - connect(2)). Doing a netstat -a shows that port 8139 is not opened.

If I start the agent in the puppet console (puppet agent --no-daemonize), everything works fine! netstat shows the port, and I can trigger the puppet runs.

So, why doesn't the service-version open this port?

btw: I tried activating debug output and logged this into a file, but the output is pretty useless, just saying the service was started and giving the PID.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-11-04 23:14:27 -0500

joshc gravatar image

The windows service does not support kick/listen for a few reasons. First, that functionality has been deprecated for a while, and will be removed in Puppet 4 ( https://tickets.puppetlabs.com/browse... ). Second, running a service as LocalSystem and accepting network connections is asking for trouble. You are better off using mcollective for the time being.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-10-24 06:24:41 -0500

Seen: 407 times

Last updated: Nov 04 '14