Ask Your Question
0

"Invalid command ProxyPassMatch" Error

asked 2014-10-27 19:53:48 -0600

schowdh gravatar image

updated 2014-10-28 15:52:37 -0600

Hi Team,

After installing monolithic PE-Puppet 3.3.2, I make ca = false in [master] section in

/etc/puppetlabs/puppet/puppet.conf

and add

SSLProxyEngine On
# Proxy all requests that start with things like /production/certificate to the CA
ProxyPassMatch ^/([^/]+/certificate.*)$ https://puppetca.example.com:8140/$1

in

/etc/puppetlabs/httpd/conf.d/puppetmaster.conf

file

Then, if I try to restart pe-httpd by running sudo /etc/init.d/pe-httpd restart

I get the following error.

Syntax error on line 9 of /etc/puppetlabs/httpd/conf.d/puppetmaster.conf:
Invalid command 'ProxyPassMatch', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
   ...fail!

In open Puppet I understand I need to install Apache and sometimes need to add specificall run a2enmod proxy_http or similar commands, but my understanding and in earlier experiments I saw pe-httpd does not need anything of this sort. But can yopu please let me know why I am seeing this error, and how to overcome the issue. I tried to install apache from https://forge.puppetlabs.com/puppetlabs/apache by running the below command but did not help.

puppet module install puppetlabs-apache

My server is a Ubuntu 14.04.1.

edit retag flag offensive close merge delete

Comments

Thanks cbarbour! I have got a solution to this now!

schowdh gravatar imageschowdh ( 2014-10-30 13:32:54 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-10-30 12:46:28 -0600

cbarbour gravatar image

updated 2014-10-30 15:18:43 -0600

The puppetlabs-apache module isn't really used for setting up the PE Apache server, so it won't help in this case.

Try the apache2ctl -M command and make sure mod_proxy is loaded. Let me know what you find. Make sure you're running the PE bundled apachectl command, not the OS supplied command.

edit flag offensive delete link more
0

answered 2014-10-30 13:27:59 -0600

schowdh gravatar image

updated 2014-10-30 13:34:47 -0600

I have got the solution now. The problem was proxy was not enabled for puppet's apache. You need to run a2enmod proxy supplied with pe-puppet. That resolves it. Anyway thanks for looking into it :).

/opt/puppet/sbin/a2enmod proxy

installing apache2 for system [using sudo apt-het install apache2] and enabling proxy on system level will not help.

edit flag offensive delete link more

Comments

Awesome. Glad that worked!

cbarbour gravatar imagecbarbour ( 2014-10-30 15:19:24 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-27 19:53:48 -0600

Seen: 2,324 times

Last updated: Oct 30 '14