Ask Your Question
1

Error 400 on SERVER: Not authorized to call find on /file_metadata/etc/puppet/modules/test/Register.war with {:links=>"manage", :source_permissions=>"use"}

asked 2014-10-30 01:56:28 -0500

abhishekb gravatar image

I want to copy/deploy a Register.war file from puppetmaster to agent node. I am using the following code

file{'/usr/share/tomcat/webapps/': source=> puppet://<hostname>/etc/puppet/modules/test/Register.war", }

But i am facing above written error.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-11-04 23:03:17 -0500

joshc gravatar image

Assuming the name of your module is "test", the source parameter needs to be:

source => "puppet://<hostname>/modules/test/Register.war"

Usually the <hostname> is the puppetmaster fqdn, in which case the source parameter can be shortened to just:

source => "puppet:///modules/test/Register.war"

And the file should reside on the puppet master in:

/etc/puppetlabs/puppet/modules/test/files/Register.war

See https://docs.puppetlabs.com/references/latest/type.html#file-attribute-source for more details.

edit flag offensive delete link more

Comments

Thanks joshc....that was helpful

abhishekb gravatar imageabhishekb ( 2014-11-05 01:14:51 -0500 )edit

I still get this error : Error: /Stage[main]/Mymodule/File[/tmp/mybash.sh]: Could not evaluate: Could not retrieve file metadata for puppet:///mymodule/files/mybash.sh: Error 500 on SERVER: Server Error: Not authorized to call find on /file_metadata/mymodule/files/mybash.sh with {:rest=>"mymodule/fi

sweety gravatar imagesweety ( 2017-01-02 19:00:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-30 01:56:28 -0500

Seen: 6,525 times

Last updated: Nov 04 '14