Ask Your Question

Error: Failed to apply catalog "\xC2" to UTF-8 in conversion from ASCII-8BIT to UTF-8 to UTF16LE

asked 2014-10-30 10:48:12 -0600

keefbaker gravatar image

updated 2014-10-30 11:07:13 -0600

Hi everyone.

I made a new puppet master, configured it and then sync'd the modules from the git repo.

Now I get the above error

"Error: Failed to apply catalog "\xC2" to UTF-8 in conversion from ASCII-8BIT to UTF-8 to UTF16LE" when trying to run a puppet run on my windows box.

I tried running the agent in debug and it gave me no suggestions as to which file might have the encoding problem.

Any ideas how I can find out which file is causing this? Thanks

Oh... puppet enterprise server is v3.3.2

edit retag flag offensive close merge delete


Have you run Puppet in debug mode? That might provide some additional context. Also, take a look at your compiled catalog on the agent. Perhaps you can search it for non-printable characters?

cbarbour gravatar imagecbarbour ( 2014-10-30 12:28:01 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2014-10-31 03:55:23 -0600

keefbaker gravatar image

Thanks, it was the encoding in my site.pp, it must have had an odd character, so I recoded it and it now works fine.

edit flag offensive delete link more


I'm glad to hear that. Encoding can be a big problem. Generally, a recursive check across everything using the unix 'file' command is a good bet for catching weirdness.

cbarbour gravatar imagecbarbour ( 2014-10-31 13:49:04 -0600 )edit

answered 2015-08-21 01:25:14 -0600

I had the same issue.

I found this oneline

for f in find | egrep -v Eliminate; do echo "$f" ' -- ' file -bi "$f" ; done

And all my encodings where charset=us-ascii

While my system was utf-8.

Then run encoding:

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-10-30 10:48:12 -0600

Seen: 394 times

Last updated: Oct 31 '14