Ask Your Question
0

Error: Package: ruby-augeas-0.4.1-3.el6.x86_64 (puppetlabs-deps)

asked 2014-11-02 12:56:32 -0500

VJ Gandla gravatar image

updated 2014-11-03 03:34:19 -0500

domcleal gravatar image

While installing puppet RHEL 6.5 I am getting following error:

--> Finished Dependency Resolution
Error: Package: rubygem-json-1.5.5-3.el6.x86_64 (puppetlabs-deps)
           Requires: rubygems >= 1.3.7
Error: Package: rubygem-json-1.5.5-3.el6.x86_64 (puppetlabs-deps)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-json-1.5.5-3.el6.x86_64 (puppetlabs-deps)
           Requires: libruby.so.1.8()(64bit)
Error: Package: puppet-3.7.2-1.el6.noarch (puppetlabs-products)
           Requires: ruby(selinux)
Error: Package: hiera-1.3.4-1.el6.noarch (puppetlabs-products)
           Requires: ruby >= 1.8.5
Error: Package: rubygem-json-1.5.5-3.el6.x86_64 (puppetlabs-deps)
           Requires: /usr/bin/ruby
Error: Package: hiera-1.3.4-1.el6.noarch (puppetlabs-products)
           Requires: /usr/bin/ruby
Error: Package: ruby-augeas-0.4.1-3.el6.x86_64 (puppetlabs-deps)
           Requires: libaugeas.so.0(AUGEAS_0.8.0)(64bit)
Error: Package: 1:facter-2.3.0-1.el6.x86_64 (puppetlabs-products)
           Requires: ruby >= 1.8.7
Error: Package: ruby-augeas-0.4.1-3.el6.x86_64 (puppetlabs-deps)
           Requires: ruby(abi) = 1.8
Error: Package: ruby-augeas-0.4.1-3.el6.x86_64 (puppetlabs-deps)
           Requires: libaugeas.so.0(AUGEAS_0.11.0)(64bit)
Error: Package: ruby-augeas-0.4.1-3.el6.x86_64 (puppetlabs-deps)
           Requires: libaugeas.so.0()(64bit)
Error: Package: ruby-augeas-0.4.1-3.el6.x86_64 (puppetlabs-deps)
           Requires: libaugeas.so.0(AUGEAS_0.12.0)(64bit)
Error: Package: ruby-augeas-0.4.1-3.el6.x86_64 (puppetlabs-deps)
           Requires: augeas-libs >= 0.8.0
Error: Package: 1:facter-2.3.0-1.el6.x86_64 (puppetlabs-products)
           Requires: /usr/bin/ruby
Error: Package: ruby-augeas-0.4.1-3.el6.x86_64 (puppetlabs-deps)
           Requires: libaugeas.so.0(AUGEAS_0.10.0)(64bit)
Error: Package: 1:ruby-shadow-2.2.0-2.el6.x86_64 (puppetlabs-deps)
           Requires: ruby
Error: Package: puppet-3.7.2-1.el6.noarch (puppetlabs-products)
           Requires: /usr/bin/ruby
Error: Package: puppet-3.7.2-1.el6.noarch (puppetlabs-products)
           Requires: ruby >= 1.8
Error: Package: puppet-3.7.2-1.el6.noarch (puppetlabs-products)
           Requires: ruby >= 1.8.7
Error: Package: ruby-augeas-0.4.1-3.el6.x86_64 (puppetlabs-deps)
           Requires: libaugeas.so.0(AUGEAS_0.1.0)(64bit)
Error: Package: ruby-augeas-0.4.1-3.el6.x86_64 (puppetlabs-deps)
           Requires: libruby.so.1.8()(64bit)
Error: Package: 1:ruby-shadow-2.2.0-2.el6.x86_64 (puppetlabs-deps)
           Requires: libruby.so.1.8()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@localhost Desktop]# 

Please help me to resolve this.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-11-03 03:36:30 -0500

domcleal gravatar image

The errors suggest that Ruby and other core packages from RHEL aren't available. Check that you have the RHEL base OS repositories configured, either from installation media (DVD etc), or preferably by registering to RHN or a Satellite.

You will probably also need to ensure the RHEL 6 Optional repository is enabled. If using RHN and subscription manager, use subscription-manager repos --enable=rhel-6-server-optional-rpms.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-11-02 12:56:32 -0500

Seen: 1,316 times

Last updated: Nov 03 '14