apply seams to ignore modulepath

asked 2014-11-03 10:52:07 -0500

finsterwalder gravatar image

Hi there,

I have a strange problem that used to work and I can't remember changing anything besides upgrading to newer versions of puppet. I use puppet 3.7.2 now. And the config and everything looks ok to me.

Here is what happens: When I execute: sudo puppet apply -e "include mod::manifest"

I get an Error: Error: Could not find class mod::manifest for .....

When I give a modulepath, everything works fine: sudo puppet apply --modulepath /puppet/modules -e "include mod::manifest"

But the same modulepath is also configured in my environment. Here are the config files:

/etc/puppet.conf

[main]
logdir=/var/log/puppet
vardir=/var/lib/puppet
ssldir=/var/lib/puppet/ssl
rundir=/var/run/puppet
factpath=$vardir/lib/facter

environmentpath = $confdir/environments
report=true
pluginsync=true

/etc/puppet/environments/production/environment.conf

manifest=/puppet/manifests
modulepath=/puppet/modules

sudo puppet config print | grep module

modulerepository = https://forgeapi.puppetlabs.com
module
workingdir = /var/lib/puppet/puppet-module
module
skeletondir = /var/lib/puppet/puppet-module/skeleton
module
groups =
basemodulepath = /etc/puppet/modules:/usr/share/puppet/modules
modulepath = /puppet/modules

Any ideas what is going wrong? Like I said, I'm pretty sure this used to work a while ago. Maybe a few month at the most.

Thanks, Malte

edit retag flag offensive close merge delete