Ask Your Question
0

install exe package in windows client

asked 2014-11-03 19:57:00 -0500

t.shenhao gravatar image

updated 2014-11-06 10:17:46 -0500

joshc gravatar image

Environment Server: Puppet Enterprise 3.3.2 + CentOS 6.5 Client: Puppet Enterprise 3.3.2 + Windows Server 2008 R2

I try to copy installation file from server to client and install in client. The problem is the file can be transferred. But install always generate error: "Failed to install: Incorrect function."

Here is the script:

class install_exe{
    file { "c:\\npp.6.5.5.Installer.exe":
            ensure => present,
            source => "puppet:///modules/install_exe/npp.6.5.5.Installer.exe",
            notify => Package["npp"],
         }
    package { "npp":
            ensure => installed,
            source => "c:\\npp.6.5.5.Installer.exe",
            require => File["c:\\npp.6.5.5.Installer.exe"],
            install_options => ['/VERYSILENT','/SUPPRESSMSGBOXES','/LOG'],
            }
    }
edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
1

answered 2014-11-03 20:58:02 -0500

t.shenhao gravatar image

updated 2014-11-06 10:14:51 -0500

joshc gravatar image

I have modified the script. Now it can run and it shows done in console. But in client, it stuck in installation. What else I need to put? It seems I need to put some parameter to do the installation. Could anyone share any opinion about it?

class install_exe{
    file { "c:\\npp.6.5.5.Installer.exe":
            ensure => "file",
            owner => 'Administrator',
            group => 'Users',
            mode => '0644',
            source => "puppet:///modules/install_exe/npp.6.5.5.Installer.exe",
            notify => Package["npp"],
         }
    package { "npp":
            ensure => installed,
            source => "c:\\npp.6.5.5.Installer.exe",
            require => File["c:\\npp.6.5.5.Installer.exe"],
            }
    }
edit flag offensive delete link more
0

answered 2014-11-06 10:19:57 -0500

joshc gravatar image

You need to add back the install_options parameter to perform a silent install. Also are you sure that npp accepts /VERYSILENT, etc? I thought it required /S for silent install?

edit flag offensive delete link more
0

answered 2016-08-06 12:37:08 -0500

npp accepts /S only

edit flag offensive delete link more
0

answered 2014-11-12 02:45:43 -0500

When attempting to installing software on windows. I took the following steps

  • I attempt to install the application manually via the command line in silent mode
  • Once found out use the parameters to populate the install options within puppet
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-03 19:57:00 -0500

Seen: 2,504 times

Last updated: Nov 06 '14