Reports not showing up in Puppetboard

asked 2014-11-06 10:14:57 -0500

scottnl gravatar image

updated 2014-11-06 17:32:03 -0500

I have puppetmaster, puppetdb, and puppetboard running on the same machine. I think it's mostly working. When I run puppet agent -t, on my node. I get my test configuration applied (creating a file on the desktop). So communication between the master and node is working.

When I log into puppetboard, I see the node listed, the facts, the catalog complied time, but there's a circle with slash under "Last Report". When I click on the node, it says "Report uploaded at" ... "Unknown". Is that normal? I was hoping to see what configuration was applied?

Here's my puppet.conf from the Master: /etc/puppet/puppet.conf

[main]
logdir=/var/log/puppet
vardir=/var/lib/puppet
ssldir=/var/lib/puppet/ssl
rundir=/var/run/puppet
factpath=$vardir/lib/facter
templatedir=$confdir/templates
dns_alt_names=puppet,puppet.local,10.211.55.55
reports = store, puppetdb, http
reporturl = http://puppet/reports/upload
storeconfigs = true
storeconfigs_backend = puppetdb


[master]
# These are needed when the puppetmaster is run by passenger
# and can safely be removed if webrick is used.
ssl_client_header = SSL_CLIENT_S_DN
ssl_client_verify_header = SSL_CLIENT_VERIFY
reports = store, puppetdb, http
reporturl = http://puppet/reports/upload
storeconfigs = true
storeconfigs_backend = puppetdb

Here's my puppetdb.conf from the Master: /etc/puppet/puppetdb.conf

[main]
server = puppet
port = 8081
soft_write_failure = false

Here's my routes.yaml from the Mater: /etc/puppet/routes.yaml

---
master:
  facts:
    terminus: puppetdb
    cache: yaml

At this point, I don't know what else to check on then to keep fiddling around with the 3 config files above. Any help or point in the right direction would be much appreciated.

I've attached a couple screens shots:

image description

image description

image description

edit retag flag offensive close merge delete

Comments

Did you find the solution?

Adam Ryczkowski gravatar imageAdam Ryczkowski ( 2015-03-11 03:56:44 -0500 )edit