Ask Your Question

Getting parser "not parse for environment production" on code from the documentatio

asked 2014-11-06 17:22:30 -0600

AntonioCS gravatar image

updated 2014-11-07 09:31:49 -0600

NOTE: I am using puppet 3.4.3. I have also tried runnint the manifest file with puppet 3.7.3 and I get the same error.

The project is on github:

you can see all the settings there.


So I have installed the php and mysql modules (and some other modules). Here is the list: puppet module list --modulepath modules/

├── bootstrap (???)

├── nodes-php (v0.9.0)

├── puppetlabs-apache (v1.1.1)

├── puppetlabs-apt (v1.7.0)

├── puppetlabs-concat (v1.1.1)

├── puppetlabs-gcc (v0.2.0)

├── puppetlabs-git (v0.2.0)

├── puppetlabs-inifile (v1.1.4)

├── puppetlabs-mysql (v2.3.1)

├── puppetlabs-stdlib (v4.3.2)

├── puppetlabs-vcsrepo (v1.1.0)

I am just pasting example code from the mysql puppet module documentation page

class { '::mysql::server': rootpassword => 'strongpassword', overrideoptions => { 'mysqld' => { 'max_connections' => '1024' } } }

and I get this when I run puppet parser validate

Error: Could not parse for environment production: Syntax error at 'class' at C:/puppet-development-stack/manifests/default.pp:17

If I remove this I get an error on this line: include php

Error: Could not parse for environment production: Syntax error at 'class' at C:/puppet-development-stack/manifests/default.pp:33

What am I doing wrong here? I just copy pasted these lines from the documentation of the modules and as you can see the modules are installed.


edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2014-11-09 07:05:11 -0600

vmule gravatar image

Hello on line 12:



include apache::mod::rewrite

see also:

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-11-06 17:22:30 -0600

Seen: 843 times

Last updated: Nov 09 '14