Ask Your Question
0

Puppetlabs-inifile module doesn't let you change key_val_separator

asked 2014-11-12 22:29:54 -0500

swarly gravatar image

It appears that the puppetlabs-inifile module does not let you modify the keyvalseparator, although the docs say you can? For example, this piece of code:

ini_setting { "blah":
    ensure  => present,
    key_val_separator => ':',
    path    => '/etc/blah-file',
    setting => 'somekey',
    value   => 'somevalue',
  }

throws an error:

:keyvalseparator must contain exactly one = character.

Any ideas would be appreciated. Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-11-18 09:16:50 -0500

swarly gravatar image

So this inifile module allows you to create child providers, that would be better suited for an ini file that uses say colons (:) (as in my example).

I opted not to sink the time into developing a new provider (although I'm surprised one doesn't already exist for colons), but instead went with the file_lib resource type that you can find in the stdlib module.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-12 22:29:54 -0500

Seen: 150 times

Last updated: Nov 18 '14