Ask Your Question
0

Can you upgrade puppet agents before your puppet master?

asked 2014-11-29 13:57:08 -0500

I'm working in a fairly new PE environment. We're in our first 6 months of Puppet, including some architecture, setup workflow stuff and the early stages of developing code. I'm also the AWS administrator, with a sizable project looking to move into AWS with a very aggressive timeline. We're looking to rely heavily on Puppet for this environment, and because of that, there are some mismatches between the roadmap for each project. In short, we're still running PE 3.3 in production and dev, however, because we use VPCs in AWS, I'm really chomping at the bit to get my hands on Facter 2, which ships with the PE 3.7 agent. We're looking to set up a test instance to model the upgrade from 3.3 to 3.7, but in a first in-place upgrade, we saw some issues (There's a lot of changes, they're documented, we're going through it all) but in short, the Puppet team is hesitant to move too quickly to using 3.7.

So my question is, is there any precedence, or common understanding around the ability to upgrade puppet agents to a revision higher than the Puppet master? Docs seem to order things in terms of master first, but I haven't seen anything specifically pointing out that this isn't a viable option. This could also be useful information in terms of rollback of a PE upgrade, if the agent upgrades go out, but the new version master has an issue, and we have to revert to pointing at an older master.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-12-01 18:07:16 -0500

inhumantsar gravatar image

The docs state that old clients can work off a new server but the opposite is likely to encounter problems. Granted, this isn't a guarantee. Nothing is going to die or error out simply because of a version mismatch. It does mean that client runs could be unpredictable if the client is newer than the server. eg: Running 3.6.2 on the clients and 3.6.0 on the servers probably won't break anything but running 3.7 on the clients and 3.3 on the server probably would.

TL;DR: Upgrade the server versions first.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-29 13:57:08 -0500

Seen: 443 times

Last updated: Dec 01 '14