Ask Your Question
0

puppet cert sign

asked 2014-12-04 05:23:32 -0500

Chutki gravatar image

Hi,

I want to check whether my master refer abcd.hdt.com agent.

I tried

puppet cert name

Warning: Setting manifestdir is deprecated. See http://links.puppetlabs.com/env-settings-deprecations
   (at /usr/lib/ruby/site_ruby/1.8/puppet/settings.rb:1139:in `issue_deprecation_warning')
Error: Invalid method name to apply

also I used

puppet cert sign abcd.hdt.com 

Warning: Setting manifestdir is deprecated. See http://links.puppetlabs.com/env-settings-deprecations
   (at /usr/lib/ruby/site_ruby/1.8/puppet/settings.rb:1139:in `issue_deprecation_warning')
Error: Could not find certificate request for abcd.hdt.com

how to check master refer the correct agent. also I tired facter command but it showing other agent details, not belog to abcd.hdt.com

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-12-04 07:58:59 -0500

jeffreyw gravatar image

Hello, I am pretty new to Puppet myself too, but just a few days ago, I got my master and agent talking with each other too.

[To the more experienced people reading my post, please correct me if I am incorrect in any of my information! I will gladly take any criticism to further improving myself]

My guess is.. from this warning, it seems like it might be referencing a manifestdir setting in your /etc/puppet/puppet.conf

If that is the case, try to take away that line setting your manifestdir.

You also have to make sure that you can reach your master server from your agent server via hostname. You can add your master server to your DNS or, in my case, I just added an entry into my agent's /etc/hosts:

#/etc/hosts
127.0.0.1 localhost
::1       localhost
192.168.1.200 puppetServer

In my agent's /etc/puppet/puppet.conf, the only additional setting I added under [main] was

server=puppetServer

Next, you should test that you can reach your master server by pinging it for example

ping puppetServer

So I think that if you remove your manifestdir setting within your /etc/puppet/puppet.conf and ensure that you can get the agent talking with the master, your cert signing should work.

I hope this helps!

edit flag offensive delete link more

Comments

Thanks, removed manifestdir from puppet.conf. Not getting deprecated error.But still I am unable to connect "abcd.hdt.com" agent to master.I tried to "puppet cert --generate abcd.hdt.com" & "puppet cert --sign abcd.htd.com" on master got "Error: Could not find certificate request for abcd.htd.com"

Chutki gravatar imageChutki ( 2014-12-08 23:52:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-12-04 05:23:32 -0500

Seen: 591 times

Last updated: Dec 04 '14